可搜索,可注册,可登录,致敬逗比大佬!尽在救援版逗比根据地 dbgjd.com
投稿文章 | 广告合作 | Telegram 群组 / 公告频道 / 使用教程

『原创』Go语言轻量化 网络混淆代理工具 —— Lightsocks 一键脚本

逗比 Toyo 279℃ 0评论

一个轻量级网络混淆代理,基于 SOCKS5 协议。只专注于混淆,用最简单高效的混淆算法达到目的;不会放大传输流量,传输流量更少更快,占用资源更少。

发现这两年很多代理软件都在用 Go 语言编写,好几个都是。目前封的严反正我是多搞一些小众代理软件,多个软件多条路。

注意:Lightsocks 不支持自定义密码,程序会自动生成超长高安全性密码,端口可以自定义。

客户端辅助工具:『原创』更方便的Windows系统 Lightsocks 客户端 —— Lightsocks Tools


系统要求

CentOS 6+ / Debian 6+ / Ubuntu 14.04 +

推荐 Debian 8 x64,这个是我一直使用的系统,我的脚本在这个系统上面出错率最低。

脚本版本

Ver: 1.0.1

安装步骤

执行下面的代码下载并运行脚本。

wget -N --no-check-certificate https://raw.githubusercontent.com/ToyoDAdoubiBackup/doubi/master/lightsocks.sh && chmod +x lightsocks.sh && bash lightsocks.sh 

运行脚本后会出现脚本操作菜单,选择并输入 1 就会开始安装。

请输入 Lightsocks 端口 [1-65535](端口不能重复,避免冲突) (默认: 随机端口):  ========================  端口 :   ========================  [信息] Lightsocks 停止成功 ! [信息] Lightsocks 启动中... [信息] Lightsocks 启动成功 ! ————————————————   Lightsocks 信息 :   地址 : x.x.x.x  端口 : 51285  密码 : xxxxxxxxx  伪装 : 无  链接 : lightsocks://xxx  二维码   : http://doub.pw/qr/qr.php?text=lightsocks://xxx  ———————————————— 

使用说明

进入下载脚本的目录并运行脚本:

./lightsocks.sh 

然后选择你要执行的选项即可。

 Lightsocks 一键管理脚本 [vx.x.x]  ---- Toyo | dbgjd.com/lightsocks-jc1 ----   0. 升级脚本 ————————————  1. 安装 Lightsocks  2. 升级 Lightsocks  3. 卸载 Lightsocks ————————————  4. 启动 Lightsocks  5. 停止 Lightsocks  6. 重启 Lightsocks ————————————  7. 设置 账号配置  8. 查看 账号信息  9. 查看 日志信息 10. 查看 链接信息 ————————————   当前状态: 已安装 并 已启动   请输入数字 [0-10]: 

其他操作

启动:/etc/init.d/lightsocks start

停止:/etc/init.d/lightsocks stop

重启:/etc/init.d/lightsocks restart

查看状态:/etc/init.d/lightsocks status

安装目录:/usr/local/lightsocks

配置文件:/root/.lightsocks.json

日志文件:/usr/local/lightsocks/lightsocks.log

其他说明

因为 Lightsocks 目前不能自定义配置文件位置,所以默认会把配置文件放在用户目录下

例如管理员用户 root 就是 /root/.lightsocks.json,例如普通用户 abc 就是 /home/.lightsocks.json

注意:Lightsocks 不支持自定义密码,程序会自动生成超长高安全性密码,端口可以自定义。


提示wget: unknown host “raw.githubusercontent.com” 之类的错误

这是无法解析我的域名,多半是DNS的问题,请更换DNS为谷歌DNS(以下两行一起复制 一起执行)。

echo -e "nameserver 8.8.8.8/nnameserver 8.8.4.4" > /etc/resolv.conf 

提示 wget: command not found 的错误

这是你的系统精简的太干净了,wget都没有安装,所以需要安装wget。

# CentOS系统: yum install -y wget  # Debian/Ubuntu系统: apt-get install -y wget 

升级脚本

升级脚本只需要重新下载脚本文件就可以了,会自动覆盖原文件。

更新日志

2018年07月10日,版本 v1.0.1

1. 新增 升级脚本时,将一起升级服务脚本(Service)。

2018年03月12日,版本 v1.0.0

1. 推出 正式版。

转载请注明:逗比根据地 » 『原创』Go语言轻量化 网络混淆代理工具 —— Lightsocks 一键脚本

喜欢 (0)
发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址